import Foundation
let pattern = #"([^\\])(fun)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Czterdzieści [tex]fun{4}\fun{5}fun{6}[/tex] lat minęło"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\\fun"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)