const regex = /([^\\])(fun)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\\])(fun)', 'gm')
const str = `Czterdzieści [tex]fun{4}\\fun{5}fun{6}[/tex] lat minęło`;
const subst = `\1\\fun`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);