package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\\])(fun)`)
var str = `Czterdzieści [tex]fun{4}\fun{5}fun{6}[/tex] lat minęło`
var substitution = "\1\\fun"
fmt.Println(re.ReplaceAllString(str, substitution))
}