using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(.+?):";
string substitution = @"<img src=""http://2ch.eq/src/$1.jpg"" />";
string input = @"blabla :KOKO: blabla :YOBA: bla";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}