$re = '/:(.+?):/';
$str = 'blabla :KOKO: blabla :YOBA: bla';
$subst = "<img src=\"http://2ch.eq/src/$1.jpg\" />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;