re = /:(.+?):/
str = 'blabla :KOKO: blabla :YOBA: bla'
subst = '<img src="http://2ch.eq/src/$1.jpg" />'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result