import re
regex = re.compile(r":(.+?):")
test_str = "blabla :KOKO: blabla :YOBA: bla"
subst = "<img src=\"http://2ch.eq/src/$1.jpg\" />"
result = regex.sub(subst, test_str)
if result:
print(result)