import Foundation
let pattern = #":(.+?):"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"blabla :KOKO: blabla :YOBA: bla"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src="http://2ch.eq/src/$1.jpg" />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)