use strict;
my $str = 'blabla :KOKO: blabla :YOBA: bla';
my $regex = qr/:(.+?):/p;
my $subst = '<img src="http://2ch.eq/src/$1.jpg" />';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";