// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":(.+?):").unwrap();
let string = "blabla :KOKO: blabla :YOBA: bla";
let substitution = "<img src=\"http://2ch.eq/src/$1.jpg\" />";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}