package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([^/]|^)(www)`)
var str = `www.ni@gmail.com"
www.google.com find me on this www.somethin.com
http://www.google.com
`
var substitution = "$1http://$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}