import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^/]|^)(www)";
final String string = "www.ni@gmail.com\"\n"
+ "www.google.com find me on this www.somethin.com\n"
+ "http://www.google.com\n";
final String subst = "$1http://$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}