const regex = /([^/]|^)(www)/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\/]|^)(www)', 'mig')
const str = `www.ni@gmail.com"
www.google.com find me on this www.somethin.com
http://www.google.com
`;
const subst = `$1http://$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);