$re = '/([^/]|^)(www)/mi';
$str = 'www.ni@gmail.com"
www.google.com find me on this www.somethin.com
http://www.google.com
';
$subst = "$1http://$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;