// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([^/]|^)(www)").unwrap();
let string = "www.ni@gmail.com\"
www.google.com find me on this www.somethin.com
http://www.google.com
";
let substitution = "$1http://$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}