import Foundation
let pattern = #"([^/]|^)(www)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
www.ni@gmail.com"
www.google.com find me on this www.somethin.com
http://www.google.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1http://$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)