import re
regex = re.compile(r"([^/]|^)(www)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("www.ni@gmail.com\"\n"
"www.google.com find me on this www.somethin.com\n"
"http://www.google.com\n")
subst = "$1http://$2"
result = regex.sub(subst, test_str)
if result:
print(result)