use strict;
my $str = 'www.ni@gmail.com"
www.google.com find me on this www.somethin.com
http://www.google.com
';
my $regex = qr/([^/]|^)(www)/mip;
my $subst = '$1http://$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";