re = /([^\/]|^)(www)/mi
str = 'www.ni@gmail.com"
www.google.com find me on this www.somethin.com
http://www.google.com
'
subst = '$1http://$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result