#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$plugins\.(\w+)\.(.+)"
Local $sString = "$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb"
Local $sSubst = "plugins.\1.process_conditions.variabilities.\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)