import re
regex = re.compile(r"\$plugins\.(\w+)\.(.+)")
test_str = "$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb"
subst = "plugins.\\1.process_conditions.variabilities.\\2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)