// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$plugins\.(\w+)\.(.+)").unwrap();
let string = "$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb";
let substitution = "plugins.\\1.process_conditions.variabilities.\\2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}