import Foundation
let pattern = #"\$plugins\.(\w+)\.(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"plugins.\1.process_conditions.variabilities.\2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}