re = /\$plugins\.(\w+)\.(.+)/
str = '$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb'
subst = 'plugins.\\1.process_conditions.variabilities.\\2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result