package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$plugins\.(\w+)\.(.+)`)
var str = []byte(`$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb`)
var substitution = []byte("plugins.\1.process_conditions.variabilities.\2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}