const regex = new RegExp('\\$plugins\\.(\\w+)\\.(.+)', '')
const str = `\$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb`;
const subst = `plugins.\1.process_conditions.variabilities.\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);