use strict;
my $str = '$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb';
my $regex = qr/\$plugins\.(\w+)\.(.+)/p;
my $subst = 'plugins.\\1.process_conditions.variabilities.\\2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";