$re = '/\$plugins\.(\w+)\.(.+)/';
$str = '$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb';
$subst = "plugins.\1.process_conditions.variabilities.\2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;