# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d+\h+Se\b/\n$0/gm;t' <<< "1 hinge 2pk
1 Se wall cabinet
4 door 15x40\""