import Foundation
let pattern = #"^\d+\h+Se\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 hinge 2pk
1 Se wall cabinet
4 door 15x40"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)