#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d+\h+Se\b"
Local $sString = "1 hinge 2pk" & @CRLF & _
"1 Se wall cabinet " & @CRLF & _
"4 door 15x40""
Local $sSubst = "\n$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)