using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\h+Se\b";
string substitution = @"\n$0";
string input = @"1 hinge 2pk
1 Se wall cabinet
4 door 15x40""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}