const regex = /^\d+\h+Se\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\h+Se\\b', 'gm')
const str = `1 hinge 2pk
1 Se wall cabinet
4 door 15x40"`;
const subst = `\n$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);