$re = '/^\d+\h+Se\b/m';
$str = '1 hinge 2pk
1 Se wall cabinet
4 door 15x40"';
$subst = "\n$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;