// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+\h+Se\b").unwrap();
let string = "1 hinge 2pk
1 Se wall cabinet
4 door 15x40\"";
let substitution = "\\n$0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}