import re
regex = re.compile(r"^\d+\h+Se\b", flags=re.MULTILINE)
test_str = ("1 hinge 2pk\n"
"1 Se wall cabinet \n"
"4 door 15x40\"")
subst = "\\n$0"
result = regex.sub(subst, test_str)
if result:
print(result)