re = /^\d+\h+Se\b/m
str = '1 hinge 2pk
1 Se wall cabinet
4 door 15x40"'
subst = '\\n$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result