# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(S)([0-9])/\1-\2/gm;t' <<< "TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4"