// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(S)([0-9])").unwrap();
let string = "TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4";
let substitution = "\\1-\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}