use strict;
my $str = 'TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4';
my $regex = qr/(S)([0-9])/mp;
my $subst = '\\1-\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";