using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(S)([0-9])";
string substitution = @"\1-\2";
string input = @"TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}