import Foundation
let pattern = #"(S)([0-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1-\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)