re = /(S)([0-9])/m
str = 'TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4'
subst = '\\1-\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result