import re
regex = re.compile(r"(S)([0-9])", flags=re.MULTILINE)
test_str = ("TRS34\n"
"MMH22\n"
"GFSR104\n"
"GS23\n"
"RRTM55\n"
"P3\n"
"S4")
subst = "\\1-\\2"
result = regex.sub(subst, test_str)
if result:
print(result)