import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(S)([0-9])";
final String string = "TRS34\n"
+ "MMH22\n"
+ "GFSR104\n"
+ "GS23\n"
+ "RRTM55\n"
+ "P3\n"
+ "S4";
final String subst = "\\1-\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}