package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(S)([0-9])`)
var str = `TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4`
var substitution = "\1-\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}