# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d*)(.+?)(,)()/ $1 $2\n$4/gm;t' <<< "1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\d*)(.*?)(,)()[WITH] $1 $2
$4"