import Foundation
let pattern = #"(\d*)(.+?)(,)()"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\d*)(.*?)(,)()[WITH] $1 $2
$4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $1 $2\n$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)