const regex = /(\d*)(.+?)(,)()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)(.+?)(,)()', 'gm')
const str = `1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\\d*)(.*?)(,)()[WITH] \$1 \$2
\$4`;
const subst = ` $1 $2\n$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);