use strict;
my $str = '1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\\d*)(.*?)(,)()[WITH] $1 $2
$4';
my $regex = qr/(\d*)(.+?)(,)()/mp;
my $subst = ' $1 $2\\n$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";